YunTech
:::
您現在的位置:首頁 arrow 最新消息 arrow Apache Struts 2.3.X系列版本中的Showcase應用程式存在允許攻擊者遠端執行任意程式碼之漏洞

  Apache Struts 2.3.X系列版本中的Showcase應用程式存在允許攻擊者遠端執行任意程式碼之漏洞
張貼日期:2017-07-11  

貼到Twitter 貼到Facebook   貼到Plurk  

 台灣電腦網路危機處理暨協調中心(TWCERT/CC)

https://www.twcert.org.tw/twcert/advdetail/3396

發佈日期    2017-07-10 10:18:38

標題  

 Apache Struts 2.3.X系列版本中的Showcase應用程式存在允許攻擊者遠端執行任意程式碼之漏洞(CVE-2017-9791),請儘速確認並進行修正(轉技服中心資訊)

CVE    CVE-2017-9791

影響平台     
Apache Struts 2.3.X的版本

說明    
1. Apache Struts 2是一個開放原始碼的Java EE網路應用程式的Web應用框架。
2.漏洞主要是在Apache Struts 2.3.X系列版本啟用Struts 2 Struts 1外掛(struct2-strust1-plugin.jar)環境下,Showcase應用程式(struct2-showcase.war)呼叫struct2-strust1-plugin時,攻擊者利用傳遞含有惡意字串的內容,造成可遠端執行任意程式碼。

解決方式    
1. 請確認網站主機是否使用Apache Struts 2 的Web應用框架,若有使用則可再透過網站主機目錄中的「WEB-INF\lib\」資料夾內的Struts.jar檔確認當前使用的版本。
2. 請確認網站主機是否使用Apache Struts 2的Showcase應用程式,路徑:\struts2.3.x\apps\struts2-showcase.war。
3. 如所使用的Apache Struts為上述(2.3.X)受影響之版本,則請更新官方網頁或官方Github所釋出最新之Apache Struts 2.5.10的版本。
4. 若無使用的需求,請關閉Showcase應用程式。

相關資訊連結  

 [1]https://www.nccst.nat.gov.tw/VulnerabilityDetail?lang=zh&seq=1064

[2]https://meterpreter.org/cve-2017-9791-apache-struts2-s2-048-remote-code-execution-vulnerability/

[3]https://cwiki.apache.org/confluence/display/WW/S2-048